守望者--AIR技术交流

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: ANE FlasCC 炼金术
查看: 13|回复: 0

[服务器环境] redis requires Ruby version >= 2.2.2问题

[复制链接]
  • TA的每日心情
    擦汗
    7 天前
  • 签到天数: 431 天

    [LV.9]以坛为家II

    1738

    主题

    2089

    帖子

    12万

    积分

    超级版主

    Rank: 18Rank: 18Rank: 18Rank: 18Rank: 18

    威望
    447
    贡献
    16
    金币
    50896
    钢镚
    1418

    开源英雄守望者

    发表于 6 天前 | 显示全部楼层 |阅读模式
            最近在研究redis的集群,redis官方提供了redis-trib.rb工具,但是在使用之前 需要安装ruby,以及redis和ruby连接:
    yum -y install ruby ruby-devel rubygems rpm-build
    gem install redis
    其中 gem install redis命令执行时出现了:
    redis requires Ruby version >= 2.2.2的报错,查了资料发现是Centos默认支持ruby到2.0.0,可gem 安装redis需要最低是2.2.2
    解决办法是 先安装rvm,再把ruby版本提升至2.3.3
    1.安装curl
    sudo yum install curl
    2. 安装RVM
    curl -L get.rvm.io | bash -s stable
    3.
    source /usr/local/rvm/scripts/rvm
    4. 查看rvm库中已知的ruby版本
    rvm list known
    5. 安装一个ruby版本
    rvm install 2.3.3
    6. 使用一个ruby版本
    rvm use 2.3.3
    7. 设置默认版本
    rvm remove 2.0.0
    8. 卸载一个已知版本
    ruby --version
    9. 再安装redis就可以了
    gem install redis



    参考博客:
    http://blog.csdn.net/lixwjava/article/details/50408070
    http://blog.csdn.net/fengye_yulu/article/details/77628094


    守望者AIR技术交流社区(www.airmyth.com)
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    
    关闭

    站长推荐上一条 /4 下一条

    QQ|手机版|Archiver|网站地图|小黑屋|守望者 ( 京ICP备14061876号

    GMT+8, 2017-10-18 08:13 , Processed in 1.187500 second(s), 31 queries .

    守望者AIR

    守望者AIR技术交流社区

    本站成立于 2014年12月31日

    快速回复 返回顶部 返回列表